$re = '/<(p|h3)[^>]*>\s*?(<a .*?><img.*?><\/a>|<img.*?>)?\s*<\/\1>/i';
$str = '<p><a ><img></a></p>
<h3><a ><img></a></h3>
<p><a ><img></a></p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);