package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<CHAR>(.*?)<\/CHAR>`)
var str = ` <MSG><KEY>name.extObject</KEY><PARAM><CHAR>Number</CHAR><CHAR>7015:188188</CHAR></PARAM></MSG>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}