import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(\\d)([A-Za-z0-9-\\-\\/]+)?";
final String string = "1/24-26 'Wuthering Heights' Onslow Ave Elizabeth Bay\n"
+ "1/24-26b 'Wuthering Heights' Onslow Ave Elizabeth Bay\n"
+ "'Wuthering Heights' 1/24-26b Onslow Ave Elizabeth Bay\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}