// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(\d)([A-Za-z0-9-\-\/]+)?").unwrap();
let string = "1/24-26 'Wuthering Heights' Onslow Ave Elizabeth Bay
1/24-26b 'Wuthering Heights' Onslow Ave Elizabeth Bay
'Wuthering Heights' 1/24-26b Onslow Ave Elizabeth Bay
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}