use strict;
my $str = 'data:image/jpeg;base64,/9a...
data:image/png;base64,/9a...';
my $regex = qr/^.*base64,(?=\/)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";