re = /^.*base64,(?=\/)/m
str = 'data:image/jpeg;base64,/9a...
data:image/png;base64,/9a...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result