$re = '/((?:^|\.)(?=[^.]*(?:saturday|sunday|weekend))[^.]*)brunch/i';
$str = 'Limit 1 per person. Limit 1 per table. Not valid for carryout. Not valid with any other offers, no cash back. Valid only for Wednesday-Friday dinner and Saturday-Sunday brunch. Not valid on federal holidays. Reservation required.
Weekend brunch brunch.';
$subst = "\1BRUNCH";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;