import Foundation
let pattern = #"((?:^|\.)(?=[^.]*(?:saturday|sunday|weekend))[^.]*)brunch"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Limit 1 per person. Limit 1 per table. Not valid for carryout. Not valid with any other offers, no cash back. Valid only for Wednesday-Friday dinner and Saturday-Sunday brunch. Not valid on federal holidays. Reservation required.
Weekend brunch brunch.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1BRUNCH"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)