import re
regex = re.compile(r"((?:^|\.)(?=[^.]*(?:saturday|sunday|weekend))[^.]*)brunch", flags=re.IGNORECASE)
test_str = ("Limit 1 per person. Limit 1 per table. Not valid for carryout. Not valid with any other offers, no cash back. Valid only for Wednesday-Friday dinner and Saturday-Sunday brunch. Not valid on federal holidays. Reservation required.\n\n\n"
"Weekend brunch brunch.")
subst = "\\1BRUNCH"
result = regex.sub(subst, test_str)
if result:
print(result)