const regex = /([^A])(?=B)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^A])(?=B)', 'gm')
const str = `XBB`;
const subst = `\1A`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);