use strict;
my $str = 'XBB';
my $regex = qr/([^A])(?=B)/mp;
my $subst = '\\1A';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";