import Foundation
let pattern = #"([^A])(?=B)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"XBB"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1A"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)