using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(remote:[a-zA-Z]+\|[^\,]+|[a-f0-9]{32})";
string input = @"remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820,remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}