re = /(remote:[a-zA-Z]+\|[^\,]+|[a-f0-9]{32})/
str = 'remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820,remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end