package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(remote:[a-zA-Z]+\|[^\,]+|[a-f0-9]{32})`)
var str = `remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820,remote:City|Vestavia Hills,AL,remote:Citystate|Vestavia Hills,395b5231539390675a7abe0751fc4820`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}