using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\D)\d{7}(?=\D|$)";
string input = @"patch-8.6.22 (1329214-1396826-Increase timeout.zip";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}