re = /(?<=\D)\d{7}(?=\D|$)/
str = 'patch-8.6.22 (1329214-1396826-Increase timeout.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end