$re = '/(?<=\D)\d{7}(?=\D|$)/';
$str = 'patch-8.6.22 (1329214-1396826-Increase timeout.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);