using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^[A-Za-z0-9]+\s?[A-Za-z0-9]+$).{3,30}";
string input = @"username123
user name 123
user name123
u sername123
username123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}