re = /(?=^[A-Za-z0-9]+\s?[A-Za-z0-9]+$).{3,30}/m
str = 'username123
user name 123
user name123
u sername123
username123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end