$re = '/(?=^[A-Za-z0-9]+\s?[A-Za-z0-9]+$).{3,30}/m';
$str = 'username123
user name 123
user name123
u sername123
username123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);