import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z])[^a-zA-Z\\n]*([a-zA-Z])?[^a-zA-Z\\n]*([a-zA-Z])?[^a-zA-Z\\n]*([a-zA-Z])?";
final String string = "Ill Fated\n"
+ "RA123 *JU23\n"
+ "MAC\n"
+ "Nagpur District";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}