const regex = /^([a-zA-Z])[^a-zA-Z\n]*([a-zA-Z])?[^a-zA-Z\n]*([a-zA-Z])?[^a-zA-Z\n]*([a-zA-Z])?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z])[^a-zA-Z\\n]*([a-zA-Z])?[^a-zA-Z\\n]*([a-zA-Z])?[^a-zA-Z\\n]*([a-zA-Z])?', 'gm')
const str = `Ill Fated
RA123 *JU23
MAC
Nagpur District`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);