$re = '/^([a-zA-Z])[^a-zA-Z\n]*([a-zA-Z])?[^a-zA-Z\n]*([a-zA-Z])?[^a-zA-Z\n]*([a-zA-Z])?/m';
$str = 'Ill Fated
RA123 *JU23
MAC
Nagpur District';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;