const regex = /(\S)(?=\s(\S))|\s+.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)(?=\\s(\\S))|\\s+.$', 'gm')
const str = `A T G C C G C G T`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);