use strict;
my $str = 'A T G C C G C G T';
my $regex = qr/(\S)(?=\s(\S))|\s+.$/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";