$re = '/(\S)(?=\s(\S))|\s+.$/m';
$str = 'A T G C C G C G T';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;