const regex = /'.*(["]).*'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'.*(["]).*\'', 'g')
const str = `"foo"
'foo'
abc "foo"
foo "bar", "baz"
abc 'foo "bar" baz'`;
const subst = `'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);