// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"'.*(["]).*'"#).unwrap();
let string = "\"foo\"
'foo'
abc \"foo\"
foo \"bar\", \"baz\"
abc 'foo \"bar\" baz'";
let substitution = "'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}