$re = '/\'.*(["]).*\'/';
$str = '"foo"
\'foo\'
abc "foo"
foo "bar", "baz"
abc \'foo "bar" baz\'';
$subst = "'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;