using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:(https?:\/\/)|\1?www\.)\w+\.\w{2,5}).*";
string input = @"http://example.com,
https://example.com,
foo
barkjsklj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}