re = /^(?!.*(?:(https?:\/\/)|\1?www\.)\w+\.\w{2,5}).*/m
str = 'http://example.com,
https://example.com,
foo
barkjsklj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end