$re = '~^(?!.*(?:(https?:\/\/)|\1?www\.)\w+\.\w{2,5}).*~m';
$str = 'http://example.com,
https://example.com,
foo
barkjsklj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);