using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^tmp_\d+-(.*?)-\d+\.(.*?)$";
string input = @"tmp_20950-test-1-5487457458.mp3";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}