const regex = /^tmp_\d+-(.*?)-\d+\.(.*?)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^tmp_\\d+-(.*?)-\\d+\\.(.*?)$', '')
const str = `tmp_20950-test-1-5487457458.mp3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}