$re = '/^tmp_\d+-(.*?)-\d+\.(.*?)$/';
$str = 'tmp_20950-test-1-5487457458.mp3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);