re = /(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail)\/(\d+).*/i
str = 'http://www.gettyimages.com/license/182149877?share=site_twitter'
# Print the match result
str.match(re) do |match|
puts match.to_s
end