package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\p{L}+(['-]\p{L}+)*\.?(\s\p{L}+(['-]\p{L}+)*\.?)+$`)
var str = `Vasa. P. Petrov.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}