$re = '/^\p{L}+([\'-]\p{L}+)*\.?(\s\p{L}+([\'-]\p{L}+)*\.?)+$/';
$str = 'Vasa. P. Petrov.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);