re = /^\p{L}+(['-]\p{L}+)*\.?(\s\p{L}+(['-]\p{L}+)*\.?)+$/
str = 'Vasa. P. Petrov.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end