const regex = /^(\d{2})\/(\d{2})\/(\d{4})(?: (?:(HOLIDAY)|(?:(?:(\d{2}:\d{2}) - (\d{2}:\d{2}))(?: (LUNCH) (\d{2}:\d{2}))?))$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2})\\\/(\\d{2})\\\/(\\d{4})(?: (?:(HOLIDAY)|(?:(?:(\\d{2}:\\d{2}) - (\\d{2}:\\d{2}))(?: (LUNCH) (\\d{2}:\\d{2}))?))$)', 'gm')
const str = `12/17/2015 09:00 - 13:00
12/18/2015 09:00 - 17:00 LUNCH 00:30
01/18/2016 HOLIDAY
01/10/2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}