// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{2})\/(\d{2})\/(\d{4})(?: (?:(HOLIDAY)|(?:(?:(\d{2}:\d{2}) - (\d{2}:\d{2}))(?: (LUNCH) (\d{2}:\d{2}))?))$)").unwrap();
let string = "12/17/2015 09:00 - 13:00
12/18/2015 09:00 - 17:00 LUNCH 00:30
01/18/2016 HOLIDAY
01/10/2016";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}