$re = '/^(\d{2})\/(\d{2})\/(\d{4})(?: (?:(HOLIDAY)|(?:(?:(\d{2}:\d{2}) - (\d{2}:\d{2}))(?: (LUNCH) (\d{2}:\d{2}))?))$)/m';
$str = '12/17/2015 09:00 - 13:00
12/18/2015 09:00 - 17:00 LUNCH 00:30
01/18/2016 HOLIDAY
01/10/2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);