#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Transaction Date: 29/05/18" & @CRLF & _
"Our reference: 037039972" & @CRLF & _
""
Local $sString = "[AA] abcd 1234 !@#$ _+{}[]:"" & @CRLF & _
"[BB]abcd defg" & @CRLF & _
"[CC]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")