using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Transaction Date: 29/05/18
Our reference: 037039972
";
string input = @"[AA] abcd 1234 !@#$ _+{}[]:""
[BB]abcd defg
[CC]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}