import re
regex = re.compile((r"Transaction Date: 29/05/18\n"
r"Our reference: 037039972\n"))
test_str = ("[AA] abcd 1234 !@#$ _+{}[]:\"\n"
"[BB]abcd defg\n"
"[CC]")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")