#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<(\w+)[^>]*>)((?!<\2).*)(<\/\2>)"
Local $sString = "alpha" & @CRLF & _
"<div>" & @CRLF & _
"alpha<div>" & @CRLF & _
"beta<div>" & @CRLF & _
"x < y divided by 4" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
" <span style="font-size: 8pt;" disabled title="data">" & @CRLF & _
" <span>infinite</span>" & @CRLF & _
" <?= $record->id ?>" & @CRLF & _
" </span>" & @CRLF & _
" <div> equal </div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div> sum </div>" & @CRLF & _
"" & @CRLF & _
"When x y and y > 0 " & @CRLF & _
"<div> Summary</div> " & @CRLF & _
"Equation id <?= $equation->id ?>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")