const regex = /(<(\w+)[^>]*>)((?!<\2).*)(<\/\2>)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<(\\w+)[^>]*>)((?!<\\2).*)(<\\\/\\2>)', 'gs')
const str = `alpha
<div>
alpha<div>
beta<div>
x < y divided by 4
</div>
</div>
</div>
<div>
<span style="font-size: 8pt;" disabled title="data">
<span>infinite</span>
<?= \$record->id ?>
</span>
<div> equal </div>
</div>
<div> sum </div>
When x y and y > 0
<div> Summary</div>
Equation id <?= \$equation->id ?>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}