import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(\\w+)[^>]*>)((?!<\\2).*)(<\\/\\2>)";
final String string = "alpha\n"
+ "<div>\n"
+ "alpha<div>\n"
+ "beta<div>\n"
+ "x < y divided by 4\n"
+ "</div>\n"
+ "</div>\n"
+ "</div>\n\n\n"
+ "<div>\n"
+ " <span style=\"font-size: 8pt;\" disabled title=\"data\">\n"
+ " <span>infinite</span>\n"
+ " <?= $record->id ?>\n"
+ " </span>\n"
+ " <div> equal </div>\n"
+ "</div>\n\n\n"
+ "<div> sum </div>\n\n"
+ "When x y and y > 0 \n"
+ "<div> Summary</div> \n"
+ "Equation id <?= $equation->id ?>\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}