const regex = /^(?<email>(?<before>[\p{L}0-9.-@#$%!_]+)@(?<after>gmail|hotmail|yahoo)(.com|.nl|.info))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<email>(?<before>[\\p{L}0-9.-@#$%!_]+)@(?<after>gmail|hotmail|yahoo)(.com|.nl|.info))$', '')
const str = `test@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}